Stöd för PHP 7 i våra webbhotellspaket

Vi strävar alltid efter att erbjuda våra kunder de senaste och bästa funktionerna, så snabbt och säkert som möjligt. Det är därför ett nöje att få berätta att vi nu har stöd för PHP 7 i våra webbhotellspaket.

Våra webbhotellskunder väljer själva enkelt sin PHP-version i vår kontrollpanel, under ”Hemsida” och ”PHP”. En PHP-version kan anges för hela kontot eller så kan man blanda olika versioner för olika mappar (hemsidor).

Vi har idag stöd för följande PHP-versioner: 5.2.17, 5.3.29, 5.4.45, 5.5.30, 5.6.16 och 7.0.

När man väljer en PHP-version så uppdateras man automatiskt inom samma huvudversion (t ex mellan 5.6.15 och 5.6.16). Uppdateringar sker minst en gång/månad (under våra servicefönster) eller mer ofta, om det behövs av säkerhetsskäl.

– Lite kort om PHP 7

PHP har gjort som Microsoft med Windows och hoppat över en version mellan 5 och 7. Även om PHP 7 är en rejäl omskrivning av PHP så är bakåtkompatibiliteten väldigt god. Om du själv utvecklar PHP så kan vi dock rekommendera PHP’s sammanställning av nyheterna i PHP 7 samt deras förteckning över tidigare funktioner, variabler m.m. som inte är kompatibla med PHP 7.

Den främsta nyheten med PHP 7 är att det är mycket snabbare än PHP-version 5.x. Våra egna tester visar att PHP 7 är 2-3 gånger snabbare än PHP 5.x. Företaget Zend, som är specialister på PHP, har publicerat en mer ingående rapport (PDF 2,4 MB) med bl a följande jämförelse mellan PHP 5.6, HHVM och PHP 7:

Hastighet på WordPress med PHP 5 och 7

PHP 7 är dock den första versionen i denna serie och kan därför både innebära en säkerhetsrisk samt orsaka tekniska störningar. Vi vill ge er möjlighet att köra PHP 7, men det sker givetvis under eget ansvar.

Många av er kommer inte uppleva några problem. Utvecklare av populära PHP-lösningar har anpassat dessa för PHP 7, men vissa är inte riktigt klara än. Några PHP-lösningar som vi vet inte fungerar (eller har problem) med PHP 7 är t ex Joomla! och Piwik.

WordPress fungerar överlag väldigt bra med PHP 7. Många tillägg är även anpassade, men det finns tillägg som kan sluta fungera eller orsaka fel med PHP 7. Så testa er WordPress-sida ordentligt om ni väljer att använda PHP 7.

– Rekommenderad PHP-version hos oss

Idag kan vi rekommendera er att använda PHP-version 5.6.16. Det är den främsta versionen i den stabila 5-serien, som i princip alla PHP-lösningar fungerar med. PHP 5.6.16 är riktigt snabb också.

Har du några frågor kring detta? Lämna gärna en kommentar här nedan!

You Might Also Like
3 Comments
  • Bruse
    says:

    Har
    ett ärende på det hos er, men testat PHP 7 på två WP-installationer och
    en egenutvecklad sajt, och jag upplever det som att med PHP7 går det en
    aningen långsammare än med PHP 5.3 eller 5.5.

    • sulo
      says:

      Det låter märkligt. PHP 7 är klart snabbare än PHP 5 enligt våra (och många andras) tester. Men det finns givetvis faktorer som kan påverka detta. Om man t ex kör en cachefunktion så är skillnaden i hastighet minimal. Oavsett vad så kommer du få ytterligare hjälp via påbörjat ärende hos vår kundtjänst.

Lämna ett svar