Aktuella uppgraderingar av SSL och PHP

FS Data förbättras hela tidenPå FS Data värnar vi om att erbjuda våra kunder så snabba, säkra och stabila tjänster som möjligt. Det är en ständigt pågående process, där en av de viktigaste delarna är att ständigt ligga i framkant av den tekniska utvecklingen.

Våra månadsvisa servicefönster är ett bra exempel på hur vi arbetar här.

Utöver våra servicefönster genomför vi även särskilda insatser för specifik mjuk- och hårdvara. Just nu arbetar vi extra med vissa uppgraderingar av SSL och PHP, som vi vill informera er om här.

– OpenSSL med TLS 1.2

Vi uppgraderar OpenSSL på samtliga Linux-baserade webbservrar. Detta berör främst kunder med SSL-certifikat installerade för sina hemsidor. Vi skiftar även till TLS 1.2, en bättre implementation av SSL som både är bakåtkompatibelt och framtidssäkrad.

Kunder med SSL-certifikat behöver inte göra något i samband med detta.

TLS 1.2 kommer att implementeras för samtliga SSL-baserade tjänster hos oss. Vi räknar inte med att våra kunder ska märka av uppgraderingen, men det kan eventuellt påverka användare med väldigt gamla SSL-klienter (webbläsare, e-postprogram osv). Det finns även en chans att tidigare utfärdade serversignaturer för SSH- och SFTP-anslutningar kan behöva uppdateras.

Men som sagt, vi gör allt för att uppgraderingen av OpenSSL och skiftet till TLS 1.2 ska gå obemärkt förbi.

– PHP 7.0 med komprimering

Vi har länge erbjudit ett brett utbud av olika PHP-versioner för våra webbhotellskunder. Som kund hos oss kan man välja mellan PHP 5.2, 5.3, 5.4, 5.5, 5.6 eller 7.0 för sin hemsida (via vår kontrollpanel). Samtliga versioner av PHP har ett frikostigt stöd för olika funktioner avseende t ex bild- och filhantering.

PHP 5-versionerna har även stöd för komprimering, vilket avsevärt snabbar upp våra kunders hemsidor. När vi införde PHP 7 i slutet av förra året så var den versionen alldeles ny och komprimeringsstödet var inte tillräckligt stabilt för vår servermiljö. Men vi har fortlöpande testat det och funnit att komprimeringen med PHP 7 nu även kan aktiveras.

Det är denna uppgradering som nu sker med PHP 7.

Vid uppgraderingen av PHP 7 så kan vissa databasanslutningar sluta fungera, om man har en hemsida eller hemsidelösning som använder en äldre databaskoppling. Om ni använder PHP 7 och märker att en databasanslutning slutar fungera, logga då in i vår kontrollpanel och byt till en PHP 5-version så kommer databasanslutningen att fungera igen.

Meddela sedan vår kundtjänst så byter vi databaskoppling manuellt. Därefter kan PHP 7 (med komprimering) användas igen.

Alla uppgraderingar sker som planerade arbeten med tydlig information publicerad på vår driftstatussida. Arbetet utförs givetvis även sen kväll/natt, när våra kunders hemsidor har så få besökare som möjligt.

Om ni har några frågor kring detta, lämna gärna en kommentar nedan eller kontakta vår kundtjänst.

You Might Also Like
Lämna ett svar